DataSIM - Connectivity Issues Reported GLOBAL SIM – Incident details

All systems operational

Connectivity Issues Reported GLOBAL SIM

Resolved
Degraded performance
Started 4 days agoLasted about 19 hours

Affected

IoT Connectivity

Degraded performance from 2:30 PM to 9:25 AM

GLOBAL

Degraded performance from 2:30 PM to 9:25 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Update
    Update

    Connectivity continues to improve, Network Engineers will monitor into tomorrow morning.

    No further updates are expected.

  • Monitoring
    Monitoring

    Service has nearly fully restored for devices outside of the North America and the UK.

    Service in North America and the UK has improved but remains degraded.

  • Identified
    Identified

    The affected carrier partner has been identified as the root cause and this issue has been resolved.

    However due to consequential network congestion some devices may continue to experience degraded behavior.

    Standard protocols are being followed to return service to normal performance, we will update when this has been completed.

  • Investigating
    Investigating
    We have received reports of connectivity issues for devices with the GLOBAL SIM. This has been raised with Core Network engineers and is being investigated.